Abuse Mailbox & Email Remediation Delays
Incident Report for Abnormal Security
Resolved
On September 15, 2022 starting at 6:10pm UTC (11:10am PT), customers may have experienced intermittent delays with the Abnormal Abuse Mailbox submissions, Search & Respond and Email Remediation. All delays has been resolved as of 7:50pm UTC (12:50pm PT).

Customers may see a backlog of messages that experienced the delays being processed in the Portal. We apologize for any inconveniences that this issue created for you.

Please contact Abnormal Support (support@abnormalsecurity.com) for any additional details.
Posted Sep 15, 2022 - 13:05 PDT
Identified
On September 15, 2022 starting at 6:10pm UTC (11:10am PT), customers may have experienced intermittent delays with the Abnormal Abuse Mailbox submissions, Search & Respond and Email Remediation. The issue has been identified and our Engineering team is working to resolve it.

We apologize for any inconveniences that this issue created for you.

Please contact Abnormal Support (support@abnormalsecurity.com) for any additional details.
Posted Sep 15, 2022 - 12:21 PDT
This incident affected: Abuse Mailbox Service, Inbound Email Protection, EMEA Data Center, AMER Data Center, and Search and Respond.