Delayed Processing of Messages
Incident Report for Abnormal Security
Resolved
We have fixed the issue. All messages are being processed within SLA.

The issue impacted about 0.2% of messages processed within this period. All messages have now been processed.
Posted Mar 18, 2020 - 11:00 PDT
Update
We are continuing to investigate this issue.
Posted Mar 18, 2020 - 09:39 PDT
Investigating
We are currently experiencing a delay in processing of messages. This seems to be impacting <1% of messages. We are currently investigating the issue.
Posted Mar 18, 2020 - 07:00 PDT
This incident affected: Inbound Email Protection.