Performance Degradation - Microsoft 365 - Exchange Online Services Impacted
Incident Report for Abnormal Security
Resolved
Microsoft has resolved their issue. All Abnormal Security systems are up and fully operational. If you have any further questions please contact support@abnormalsecurity.com
Posted Jan 14, 2021 - 19:44 PST
Monitoring
We have become aware that Microsoft O365 services are currently experiencing degraded functionality as described in this Twitter thread - https://twitter.com/MSFT365Status/status/1349897882522927104

The issue is primarily impacting access to Exchange Online services.

This degradation could affect Abnormal Security's email remediation time.
Posted Jan 14, 2021 - 18:31 PST
This incident affected: Abuse Mailbox Service and Inbound Email Protection.