Abnormal Portal Degradation
Incident Report for Abnormal Security
Resolved
This incident has been resolved. Customers should no longer be experiencing issues with long CSV downloads, delays with recording Manual Remediation and Search & Respond reports.

Please contact Abnormal Support (support@abnormalsecurity.com) for any additional details.
Posted May 12, 2022 - 14:16 PDT
Update
We are continuing to work on a fix for this issue.
Posted May 12, 2022 - 14:11 PDT
Identified
We are experiencing a performance degradation of the Abnormal Portal

Customers are seeing issues with long CSV downloads, delays with recording Manual Remediation and Search & Respond reports. There is no impact to Auto Remediation and emails are being processed as expected.

The Abnormal Team is actively investigating the cause. We apologize for any inconveniences that this ongoing issue has created for you.

Please contact Abnormal Support (support@abnormalsecurity.com) for any additional details.
Posted May 12, 2022 - 11:53 PDT
This incident affected: Portal Application, Abuse Mailbox Service, EMEA Data Center, AMER Data Center, and Search and Respond.