Remediation delay for Inbound Email Protection, Abuse Mailbox and Email Productivity
Incident Report for Abnormal Security
Resolved
Incident Resolved: As of 17:00 UTC, the remediation delay issue for Inbound Email Protection, Abuse Mailbox, and Email Productivity was resolved.

Affected Services: Inbound Email Protection, Abuse Mailbox, and Graymail

Severity Level: Major

Incident Start Time: July 16, 2024, 15:00 UTC

Incident Resolution Time: July 16, 2024, 17:00 UTC

What We're Doing: our team will monitor the system closely to ensure stability. We are also conducting a post-incident review to prevent similar issues in the future.

Questions?: For any immediate concerns, please contact us at support@abnormalsecurity.com
Posted Jul 16, 2024 - 12:58 PDT
Update
Incident Update: Remediation delays have been reduced to 1 minute or less for Inbound Email Protection, Abuse Mailbox, and Email Productivity.

Affected Services: Inbound Email Protection, Abuse Mailbox, and Productivity

Severity Level: Major

Incident Start Time: July 16, 2024, 15:00 UTC

What We're Doing: The team continues to resolve the issue, and an update on the resolution status will be shared at the next planned update time.

Next Update: In 1 hour or less.

Questions?: For any immediate concerns, please contact us at support@abnormalsecurity.com.
Posted Jul 16, 2024 - 10:12 PDT
Investigating
What Happened: On July 16, 2024, at approximately 15:00 UTC, Abnormal experienced a delay in remediation for Inbound Email Protection, Abuse Mailbox, and Graymail.

Affected Services: Inbound Email Protection, Abuse Mailbox, and Graymail

Severity Level: Major

Incident Start Time: July 16, 2024, 15:00 UTC

What We're Doing: The team has identified a fix and is actively resolving the issue. An update on the resolution status will be shared at
the next planned update time.

Next Update: In 1 hour or less.

Questions?: For any immediate concerns, please contact us at support@abnormalsecurity.com.
Posted Jul 16, 2024 - 08:55 PDT
This incident affected: AI Security Mailbox, Inbound Email Security, and Email Productivity (Graymail).