Abuse Mailbox Degradation (EU Customers Only)
Incident Report for Abnormal Security
Resolved
On March 29, at 00:00 UTC, Abnormal Security stopped processing Abuse Mailbox reported messages for a subset of EU customers. AMB processing is fully recovered as of 4/2/24 19:00 UTC. Abuse mailbox reports from during this incident period will be automatically reprocessed, and no customer action is required.

Microsoft has a planned deprecation for Outlook REST v2.0 endpoints by 03/31/2024 and requires all clients to migrate to the Graph API by that time frame. During the mandatory migration of our mail notification processing to Graph API, the team identified that the Graph API does not return a necessary value in its responses compared to the Outlook REST API. This caused Abuse Mailbox processing to come to a halt for a subset of EU customers between 3/29/24 00:00 UTC and 4/2/24 19:00 UTC

Affected Services: Abuse Mailbox

Severity Level: Major

Incident Start Time: March 29, at 00:00 UTC

Recovery: We deployed a fix at 4/2/24 19:00 UTC and confirmed that abuse mailbox processing is recovered for all affected customers

What We're Doing: Abuse mailbox reports from during this incident period will be automatically reprocessed, and no customer action is required.

Resolution Time: April 2, 2024 19:00 UTC

Next Update: No further updates.

Questions? For any immediate concerns, don't hesitate to contact us at support@abnormalsecurity.com.
Posted Apr 02, 2024 - 13:27 PDT
Monitoring
On March 29, at 00:00 UTC, Abnormal Security stopped processing Abuse Mailbox reported messages for a subset of EU customers. Those impacted have been notified. The issue is related to the mandatory Microsoft Graph API migration, where the Graph API did not return a necessary value in its responses, which caused Abuse Mailbox processing to come to a halt.

Affected Services: Abuse Mailbox

Severity Level: Major

Incident Start Time: March 29, at 00:00 UTC

What We're Doing: We're testing a fix and expect to deploy it in the next hour.

Workaround: We've been running manual recovery since 15:00 UTC on 04/02/24.

Recovery: Once the fix is rolled out, we will be reprocessing all affected Abuse Mailbox messages from the incident period

Estimated Resolution Time: TBD

Next Update: 1 Hour

Questions? For any immediate concerns, don't hesitate to contact us at support@abnormalsecurity.com.
Posted Apr 02, 2024 - 11:05 PDT
This incident affected: Abuse Mailbox Service.