Degradation of Inbound Email Protection, Graymail, Abuse Mailbox, and Search & Respond
Incident Report for Abnormal Security
Resolved
Starting at 14:15 UTC, customers may have started experiencing a delay in message remediation for Inbound Email Protection, Graymail remediation, and Abuse Mailbox processing. Also, Search & Respond may be impacted as well.
Affected Services: Inbound Email Protection, Graymail, Abuse Mailbox, and Search & Respond.
Severity Level: Major
Incident Start Time: November 14, 2023, 14:15 UTC
What We're Doing: 17:30 PM UTC: All live message processing is recovered and customers should no longer be experiencing message processing delays.

This issue has been resolved, and we are now processing messages in real-time. Our R&D team is working on the COE. Our current analysis of the root cause is as follows:
-- Our Live Scoring capability leverages several auxiliary services. One of these is the DomainAge service which inspects the age of the domain from which the email originates and employs it as a signal/attribute in judging whether the email is an attack.
-- Dependency on one of the auxiliary services is disrupting the throughput of the Live Scoring service which caused a backlog, potentially the DomainAge service.
-- This resulted in the delay of 25% of messages
-- The issue has been now resolved, and we are processing messages in real-time.


Estimated Resolution Time: 17:30 PM UTC

Questions?:
For any immediate concerns, please contact us at support@abnormalsecurity.com
Posted Nov 14, 2023 - 10:05 PST
Investigating
Starting at 14:15 UTC, customers may have started experiencing a delay in message remediation for Inbound Email Protection, Graymail remediation, and Abuse Mailbox processing. Also, Search & Respond may be impacted as well.
Affected Services: Inbound Email Protection, Graymail, Abuse Mailbox, and Search & Respond.
Severity Level: Major
Incident Start Time: November 14, 2023, 14:15 UTC
What We're Doing: We are currently investigating the issue, to determine the Root Cause and identify a fix.
Estimated Resolution Time: TBD
Next Update: 1 Hour
Questions?:
For any immediate concerns, please contact us at support@abnormalsecurity.com.
Posted Nov 14, 2023 - 08:57 PST
This incident affected: Abuse Mailbox Service, Inbound Email Protection, Email Productivity (Graymail), and Search and Respond.