Service Disruption impacting US and EU customers due to Microsoft 365 API Latency
Incident Report for Abnormal Security
Resolved
Microsoft services have remained stable. Processing for Inbound Email Security, AI Security Mailbox, and Graymail have remained at baseline levels since 22:45 UTC. A postmortem report will be available to share with customers once Microsoft has provided us with details pertaining to this incident. This incident is resolved and no further updates will be provided.

If you experience any further issues pertaining to this incident, please contact us at support@abnormalsecurity.com.
Posted Nov 25, 2024 - 16:52 PST
Monitoring
Microsoft reports that they are seeing service recovery on their end. Engineers have observed that processing times for Inbound Email Security, AI Security Mailbox, and Graymail services are slowly recovering. Our engineering teams continue to actively monitor for full service restoration. The next update will be provided when services are fully restored or more information is provided by Microsoft.
Posted Nov 25, 2024 - 14:39 PST
Update
Microsoft reports experiencing delays in their recovery efforts, which continues to impact Abnormal Security’s processing times for Inbound Email Security, AI Security Mailbox, and Graymail services. Our engineering teams continue to actively investigating optimizations to mitigate the impact of the Microsoft 365 latency. The next update will be provided when we receive further information from Microsoft about their API performance restoration.
Posted Nov 25, 2024 - 11:17 PST
Investigating
Microsoft 365 is experiencing elevated API latency, which beginning at 07:30 UTC has impacted Abnormal Security’s processing times for Inbound Email Security, AI Security Mailbox, and Graymail services. This Microsoft platform slowdown is affecting remediation times for both EU and US customers. Our engineering teams are actively implementing optimizations to mitigate the impact of the Microsoft 365 latency in the US region. EU systems are already showing improvement as Microsoft’s services recover in that region. The next update will be provided in 1 hour or when we receive further information from Microsoft about their API performance restoration.
Posted Nov 25, 2024 - 10:08 PST
This incident affected: Inbound Email Security (IES), Email Productivity (EPR), and AI Security Mailbox (AISM).