Inbound Email Security - Google Customers Only
Incident Report for Abnormal Security
Resolved
We have successfully resumed processing all GSuite email traffic in both EU and US environments. This issue was isolated to GSuite services and did not affect email delivery for our customers. It stemmed from a broader Google disruption, impacting GSuite integrations for their customers globally.

Throughout the incident, Abnormal Security services remained fully operational, ensuring ongoing protection for our customers.

Update Time: 2024-09-13 5:15 PM UTC

Next Update: No further updates.

Questions?: For any immediate concerns, please contact us at support@abnormalsecurity.com.
Posted Sep 13, 2024 - 10:33 PDT
Identified
What Happened: On 9/13 at 3:08 PM UTC, Gmail's API unexpectedly stopped connecting, causing problems with Inbound Email Security for Google Workspace customers only.

Affected Services: Inbound Email Security

Severity Level: Major

Incident Start Time: Sep 13, 2024, at 3:08 PM UTC

What We're Doing: We have contacted Google Support for further information.

Next Update: In 1 hour or less.

Questions?: For any immediate concerns, please contact us at support@abnormalsecurity.com.
Posted Sep 13, 2024 - 09:13 PDT
This incident affected: Inbound Email Security.