Delayed Processing of Messages
Incident Report for Abnormal Security
Resolved
This incident has been resolved.
Posted Jan 14, 2020 - 13:55 PST
Monitoring
We have now caught up to message processing and proactively monitoring the health of the system.
Posted Jan 14, 2020 - 13:45 PST
Update
We have rolled back to an earlier version of code and are now recovering from the outage.
Posted Jan 14, 2020 - 13:23 PST
Identified
The system which processes messages is processing very slowly. This is causing a few of our services to not function within expected times.
Posted Jan 14, 2020 - 10:45 PST
This incident affected: Notification Delivery, Abuse Mailbox Service, and Inbound Email Protection.