Performance Degredation - Delays for Inbound Detection
Incident Report for Abnormal Security
Resolved
The issue is resolved and all systems are up and fully operational. All messages have been processed and remediated. If you have any further questions please contact support@abnormalsecurity.com
Posted Oct 20, 2020 - 12:27 PDT
Investigating
We experienced an intermittent delay for Inbound detection between 8:00am and 11:30am PT. The issue is now resolved and the team is currently monitoring the situation.

If have any further questions please contact support@abnormalsecurity.com
Posted Oct 20, 2020 - 12:14 PDT
This incident affected: Inbound Email Protection.