Remediation Delay - Inbound Email Security
Incident Report for Abnormal Security
Resolved
What Happened: On September 10, 2024, at 16:00 UTC, Abnormal and its vendor partner started experiencing unknown issues, leading to elevated remediation times for Inbound Email Protection. This incident affected Microsoft and Google customers, causing delays in email remediation.

Affected Services: Inbound Email Protection

Severity Level: Major

Incident Start Time: September 10, 2024, at 16:00 UTC

Resolution: The incident was fully resolved as of September 10, 2024, at 18:45 UTC (11:45 AM PST). Remediation times have returned to normal levels.

Questions? For any immediate concerns, please contact us at support@abnormalsecurity.com.
Posted Sep 10, 2024 - 13:38 PDT
Investigating
What Happened: On 9/10 at 16:00 UTC, Abnormal and its vendor partner started experiencing unknown issues, leading to elevated remediation times for Inbound Email Protection. This incident affects Microsoft and Google customers, who can expect email remediation delays.

Affected Services: Inbound Email Protection

Severity Level: Major

Incident Start Time: Sep 10, 2024, at 16:00 UTC

What We're Doing: Our Engineering team is actively working to address the increased latency.

Next Update: In 1 hour or less.

Questions?: For any immediate concerns, please contact us at support@abnormalsecurity.com.
Posted Sep 10, 2024 - 11:29 PDT
This incident affected: Inbound Email Security.