Email Remediation Delays

Incident Report for Abnormal AI

Resolved

As of May 11, 2023 at 6:24pm UTC (11:24am PT), the remediation delays have been resolved and customers should no longer experience any further issues.

Customers may still see a backlog of messages that experienced the delays being processed in the ThreatLog. We apologize for any inconveniences that this issue created for you.

Please contact Abnormal Support (support@abnormalsecurity.com) for any additional details.
Posted May 23, 2023 - 10:24 PDT

Identified

On May 11, starting at 12:51pm UTC (5:51am PT), customers may be experiencing delays with email remediation and corresponding email appearing in the ThreatLog. The issue has been identified and is currently being investigated by the Abnormal Engineering team. We will provide an update as soon as possible.

We apologize for any inconveniences that this issue created for you.

Please contact Abnormal Support (support@abnormalsecurity.com) for any additional details.
Posted May 11, 2023 - 09:25 PDT
This incident affected: Inbound Email Security (IES).