Potential Abuse Mailbox delays for Gsuite customers
Incident Report for Abnormal Security
Resolved
As of 12:28 am UTC ( 5:48 pm PST), this incident has been resolved and will reprocess all emails submitted to the Abuse Mailbox during the incident. Users do not need to resubmit the affected emails.

We sincerely apologize for any inconvenience caused by this issue.

Please contact Abnormal Support (support@abnormalsecurity.com) for any additional details.
Posted Jul 10, 2023 - 17:01 PDT
Identified
On July 10, 2023 starting at 2:25 pm UTC ( 7:25 am PST), Google Workspace customers may experience intermittent delays with the Abuse Mailbox reported messages being analyzed. We are working on diagnosing the issue, and will provide an update as soon as possible.

This is only affecting Google Workspace customers who use the “Report Phish” option for submission to Abuse Mailbox. All other methods (forwarding to mailbox or mailing list) are operating as normal.

Microsoft 365 integrated tenants are not affected by this issue.

We apologize for any inconvenience that this issue created for you.

Please contact Abnormal Support (support@abnormalsecurity.com) for any additional details.
Posted Jul 10, 2023 - 16:02 PDT
This incident affected: AI Security Mailbox (AISM).