Abuse Mailbox Campaign Processing Delay
Incident Report for Abnormal Security
Resolved
As of 12:51 pm UTC ( 5:51 am PT), the delay in processing Abuse Mailbox submissions has been resolved. New submissions should be processed as expected going forward.

Abuse Mailbox - Fully Operational
Inbound Email Security - Fully Operational
Email Productivity - Fully Operational
Account Takeover - Fully Operational
Secure Posture Management - Fully Operational



We sincerely apologize for any inconvenience caused by this issue.

Please contact Abnormal Support (support@abnormalsecurity.com) for any additional details.
Posted Aug 25, 2023 - 06:03 PDT
Investigating
Abnormal Security customers with the Abuse Mailbox feature may experience a delay in processing new submissions. Our engineering team is working to determine the cause and resolve it as quickly as possible.


Abuse Mailbox - Degraded
Inbound Email Security - Fully Operational
Email Productivity - Fully Operational
Account Takeover - Fully Operational
Secure Posture Management - Fully Operational

We apologize for any inconvenience that this has caused you.

Please contact Abnormal Support (support@abnormalsecurity.com) for any additional details.
Posted Aug 25, 2023 - 05:03 PDT
This incident affected: Abuse Mailbox Service.