Remediation delay for Inbound Email Protection, Abuse Mailbox and Graymail

Incident Report for Abnormal Security

Resolved

Incident Resolved: On June 18, 2024, at approximately 14:45 UTC, Abnormal experienced a delay in remediation for Inbound Email Protection, Abuse Mailbox, and Graymail. The root cause was a system delay in handling large attacker activity. Recovery is now completed, and all systems are fully operational.

Affected Services: Inbound Email Protection, Abuse Mailbox, and Graymail

Severity Level: Major

Incident Start Time: June 18, 2024, 14:45 UTC

Resolution Timeline:
14:45 UTC: Live remediation starts to be delayed for Email Protection, Abuse Mailbox, and Graymail.
15:48 UTC: Recovery is in progress, and the live remediation delay starting to normalize.
16:15 UTC: Live remediation is fully recovered.

Next Steps: Our team will monitor the system closely to ensure stability. We are also conducting a post-incident review to prevent similar issues in the future.

Questions?: For any further concerns, please contact us at support@abnormalsecurity.com.
Posted Jun 18, 2024 - 09:30 PDT

Investigating

What Happened: On June 18, 2024, at approximately 14:45 UTC, Abnormal experienced a delay in remediation for Inbound Email Protection, Abuse Mailbox, and Graymail.

Affected Services: Inbound Email Protection, Abuse Mailbox, and Graymail

Severity Level: Major

Incident Start Time: June 18, 2024, 14:45 UTC

What We're Doing: Our Engineering team is actively working to address the increased latency.

Next Update: In 1 hour or less.

Questions?: For any immediate concerns, please contact us at support@abnormalsecurity.com.
Posted Jun 18, 2024 - 08:35 PDT
This incident affected: Inbound Email Security (IES), Email Productivity (EPR), and AI Security Mailbox (AISM).