Inbound Email Security - Attack remediation delays to processing time
Incident Report for Abnormal Security
Resolved
Between 19:10 and 20:57 UTC on October 7th, Abnormal experienced delayed processing of attack remediation which impacted all US data center customers. Graymail was not impacted as part of this incident. The emails not analyzed during the incident time have been fully processed and services have been recovered as of 20:57 UTC.

If you experience any further issues pertaining to this incident, please contact us at support@abnormalsecurity.com.
Posted Oct 07, 2024 - 16:20 PDT
Monitoring
Functionality to remediation processing has recovered as of 20:57 UTC. Engineers identified a large Database query, which was terminated. Processing is now back within SLA. There is a backlog which is expected to take approximately 2 hours to complete. The next update will be provided when the backlog has finished processing.
Posted Oct 07, 2024 - 14:25 PDT
Update
We are continuing to investigate this issue.
Posted Oct 07, 2024 - 14:03 PDT
Investigating
Starting at 19:10 UTC on October 7, 2024, Abnormal's attack remediation began to experience delays to processing time for both Microsoft 365 and Google Workspace customers. Graymail remediation is not affected. This is impacting all customers in the US data center. The next update will be posted in 1 hour or when further information is available.
Posted Oct 07, 2024 - 13:26 PDT
This incident affected: Inbound Email Security (IES).