Remediation delayed for Inbound Email Protection, Graymail, Abuse Mailbox, and Search & Respond
Incident Report for Abnormal Security
Resolved
This incident has been fully resolved.

On March 5, 2024, starting at 16:00 UTC (8 am PT), customers may have started experiencing a delay in message remediation for Inbound Email Protection, Graymail remediation, and Abuse Mailbox processing. Search & Respond may also be impacted as well.

The root cause is a Google Workspace incident outage for Gmail.
https://www.google.com/appsstatus/dashboard/incidents/shD5VvSGTxETw1YLbsCt

- Affected Services: Inbound Email Protection, Graymail, Abuse Mailbox, and Search & Respond.
- Severity Level: Major
- Incident Start Time: March 5, 2024, starting at 16:00 UTC (8 am PT)
- What We're Doing: Live processing is recovered for all customers from 17:00 UTC.
- Recovery
- 17:00 UTC: Live processing is recovered for all customers going forward from this time.
- 18:30 UTC: Messages affected during the incident timeline (16:00-17:00 UTC) have been processed.
- 20:50 UTC: Processing has recovered for POV customers.

- What Happened: Google Workspace experienced an incident outage for Gmail starting at 15:25 UTC. Our processing clusters currently process M365+GWorkspace traffic together; as a result, the latency on Google Workspace is causing M365 processing to also be affected.

Questions? For any immediate concerns, please contact us at support@abnormalsecurity.com.
Posted Mar 05, 2024 - 13:00 PST
Update
On March 5, 2024, starting at 16:00 UTC (8 am PT), customers may have started experiencing a delay in message remediation for Inbound Email Protection, Graymail remediation, and Abuse Mailbox processing. Search & Respond may also be impacted as well.

The root cause is a Google Workspace incident outage for Gmail.
https://www.google.com/appsstatus/dashboard/incidents/shD5VvSGTxETw1YLbsCt

- Affected Services: Inbound Email Protection, Graymail, Abuse Mailbox, and Search & Respond.
- Severity Level: Major
- Incident Start Time: March 5, 2024, starting at 16:00 UTC (8 am PT)
- What We're Doing: Live processing is recovered for all customers from 17:00 UTC.
- Recovery
- 17:00 UTC: Live processing is recovered for all customers going forward from this time.
- 18:30 UTC: Messages affected during the incident timeline (16:00-17:00 UTC) have been processed.
- (In progress) Processing is being recovered for POV customers with an ETA of recovery of 20:00 UTC.
- What Happened: Google Workspace experienced an incident outage for Gmail starting at 15:25 UTC. Our processing clusters currently process M365+GWorkspace traffic together; as a result, the latency on Google Workspace is causing M365 processing to also be affected.
Posted Mar 05, 2024 - 09:54 PST
Monitoring
On March 5, 2024, starting at 16:00 UTC (8 am PT), customers may have started experiencing a delay in message remediation for Inbound Email Protection, Graymail remediation, and Abuse Mailbox processing. Search & Respond may also be impacted as well.

- Affected Services: Inbound Email Protection, Graymail, Abuse Mailbox, and Search & Respond.
- Severity Level: Major
- Incident Start Time: March 5, 2024, starting at 16:00 UTC (8 am PT)
- What We're Doing: Live processing is recovered for all customers from 17:00 UTC.
- Recovery: Messages affected during the incident timeline (16:00-17:00 UTC) are currently being processed as part of recovery steps, with an ETA for recovery at 19:00 UTC, and no customer action is required.
- Estimated Resolution Time: March 5, 2024, 19:00 UTC
- Next Update: 2 hours
Posted Mar 05, 2024 - 09:14 PST
Investigating
On March 5, 2024, starting at 16:00 UTC (8 am PT), customers may have started experiencing a delay in message remediation for Inbound Email Protection, Graymail remediation, and Abuse Mailbox processing. Search & Respond may also be impacted as well.

- Affected Services: Inbound Email Protection, Graymail, Abuse Mailbox, and Search & Respond.
- Severity Level: Major
- Incident Start Time: March 5, 2024, starting at 16:00 UTC (8 am PT)
- What We're Doing: We are currently investigating the issue, to determine the Root Cause and identify a fix.
- Estimated Resolution Time: TBD
- Next Update: 1 Hour

Questions? For any immediate concerns, please contact us at support@abnormalsecurity.com.
Posted Mar 05, 2024 - 08:37 PST
This incident affected: Abuse Mailbox Service, Inbound Email Protection, Email Productivity (Graymail), and Search and Respond.