High rate of Spam False Positives
Incident Report for Abnormal Security
Resolved
The process for restoring messages has been completed as of 9:54 PM PDT, September 26, 2023.

We apologize for any inconvenience the issue created for you.

Please contact Abnormal Support (support@abnormalsecurity.com) for any additional details.
Posted Sep 26, 2023 - 23:46 PDT
Update
The process for restoring messages has exceeded our initial estimated completion time and is still currently underway. This is an automated process conducted by Abnormal Engineering, and thus no customer action is required.

We apologize for any inconvenience the issue created for you.

Please contact Abnormal Support (support@abnormalsecurity.com) for any additional details.
Posted Sep 26, 2023 - 20:43 PDT
Monitoring
Less than 0.02% of all messages were incorrectly remediated due to an attempted improvement for Spam efficacy between 9/26/2023 11:46 PT and 9/26/2023 12:00 PT. This has since been corrected. All incorrectly remediated messages are being restored into the correct folders. The process for restoring messages is underway and should be completed by 4:00 PM PDT, September 26, 2023. This is an automated process conducted by Abnormal Engineering, and thus no customer action is required.

We apologize for any inconvenience the issue created for you.

Please contact Abnormal Support (support@abnormalsecurity.com) for any additional details.
Posted Sep 26, 2023 - 14:22 PDT
Investigating
Starting September 26, 2023, at 11:46 am PDT a detection control update was accidentally launched, causing spam False Positives and high persistence rates.
This was reverted on September 26, 2023, at 12:00 pm PDT.
We are currently reprocessing the affected messages during this time.
We will update in 1 hour or a major update.
Posted Sep 26, 2023 - 12:45 PDT
This incident affected: Inbound Email Protection.