Degradation of Inbound Email Protection
Incident Report for Abnormal Security
Resolved
As of 11:26 PM UTC, the remediation of impacted Inbound Email Security messages from the incident period was completed.

Overview: On April 3, at 4:51 PM UTC, customers started experiencing delayed message remediation for approximately 1% of Inbound Email Protection messages. The issue has been identified and corrected. We are currently in the process of remediating impacted messages.

Affected Services: Inbound Email Security

Severity Level: Major

Incident Start Time: April 3, at 4:51 PM UTC

What We're Doing: The issue has been identified and corrected.

Recovery: As of 11:22 PM UTC, the remediation of impacted Inbound Email Security messages from the incident period was completed.

Resolution Time: April 3, at 9:05 PM UTC
Posted Apr 03, 2024 - 16:29 PDT
Update
The remediation of impacted Inbound Email Security messages from the incident period is still ongoing.

Next Update: 1 Hour

Questions? For any immediate concerns, don't hesitate to contact us at support@abnormalsecurity.com.
Posted Apr 03, 2024 - 16:03 PDT
Monitoring
On April 3, at 4:51 PM UTC, customers started experiencing delayed message remediation for approximately 1% of Inbound Email Protection messages. The issue has been identified and corrected. We are currently in the process of remediating impacted messages.

Affected Services: Inbound Email Security

Severity Level: Major

Incident Start Time: April 3, at 4:51 PM UTC

What We're Doing: The issue has been identified and corrected.

Recovery: We will be remediating impacted Inbound Email Security messages from the incident period.

Resolution Time: April 3, at 9:05 PM UTC

Next Update: 1 Hour

Questions? For any immediate concerns, don't hesitate to contact us at support@abnormalsecurity.com.
Posted Apr 03, 2024 - 14:31 PDT
This incident affected: Inbound Email Protection.