EMEA Data Center Degraded Performance
Incident Report for Abnormal Security
Resolved
What Happened: On September 16, 2024, at around 5:00 pm UTC, Abnormal experienced a degradation in performance in the EU (Azure) Data Centre. During the affected timeframe, a partial customer base would have seen email detection and remediation issues, resulting in a delay in scanning.


Affected Services: Inbound Email Security


Severity Level: Major


Geography: EMEA-based customers (partial customer base - Azure Data Centre)


Incident Start Time: September 16, 2024, 5:00 PM UTC
Incident Resolution Time: September 17, 2024, 1:00 PM UTC


What We're Doing: We completed reprocessing all impacted emails. A full Root Cause Analysis will be completed and available upon request by contacting Support.

Questions?: For any immediate concerns, please contact us at support@abnormalsecurity.com.
Posted Sep 17, 2024 - 09:53 PDT
Investigating
What Happened: On September 16, 2024, at around 5:00 pm UTC, Abnormal experienced a degradation in performance in the EU (Azure) Data Centre. During the affected timeframe, partial customer base would have seen message detection and remediation issues, resulting in a delay in scanning.


Affected Services: Inbound Email Security


Severity Level: Major


Geography: EMEA-based customers (partial customer base - Azure Data Centre)


Incident Start Time: September 16, 2024, 5:00 PM UTC
Incident Resolution Time: September 17, 2024, 1:00 PM UTC


What We're Doing: Our engineering team has resolved the issue, and emails are now being remediated as usual. We have started reprocessing all impacted emails. We will provide an update once reprocessing is completed. A full Root Cause Analysis will be completed and available upon request by contacting Support.


Next Update: We will provide an update once we can share an ETA on processing completion time


Questions?: For any immediate concerns, please contact us at support@abnormalsecurity.com.
Posted Sep 17, 2024 - 07:45 PDT
This incident affected: Inbound Email Security and EMEA Data Center.