Service Disruption due to widespread AWS outage

Incident Report for Abnormal AI

Resolved

All email security services remain stable and are operating normally. Engineers have initiated reprocessing of all messages sent during the incident window to ensure complete security coverage. If customers experience any further issues, please reach out to support@abnormalsecurity.com.
Posted Oct 20, 2025 - 17:49 PDT

Monitoring

Email detection and remediation services have recovered and live traffic is currently processing normally. Portal login availability has been restored as of 21:45 UTC. Abnormal engineers are now initiating reprocessing of all messages impacted during the incident duration to ensure complete security coverage. We will continue monitoring system performance to confirm full service stability.
Posted Oct 20, 2025 - 14:54 PDT

Update

AWS Infrastructure services are showing signs of recovery and Abnormal is actively verifying that Portal and all email security functionality has been restored. We will continue monitoring system performance and provide updates as we confirm full service restoration. Once services are fully available, we will initiate a reprocess for all messages during the impact window.
Posted Oct 20, 2025 - 13:42 PDT

Update

Abnormal continues to monitor service health while waiting for AWS services to fully recover. Our engineering team has prepared a plan to perform reprocessing of all messages from the affected time window to ensure complete security coverage. We will continue monitoring system performance and provide updates as we confirm full service restoration.

Updates from AWS can be found here: https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 10:15 PDT

Update

We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 09:39 PDT

Identified

Abnormal is seeing a resurgence of service degradation across multiple security products due to continued issues with AWS. During this time, some customers may experience issues accessing Portal, delays in email processing, threat detection, and remediation activities. Abnormal continues to actively work with AWS to resolve the underlying infrastructure issues and will reprocess all affected emails once services are fully restored to ensure complete security coverage.
Posted Oct 20, 2025 - 07:56 PDT

Monitoring

AWS Infrastructure services are beginning to recover and Abnormal is actively verifying that all email security functionality has been restored. Our engineering team has initiated reprocessing of all messages from the affected time window to ensure complete security coverage. We will continue monitoring system performance and provide updates as we confirm full service restoration.
Posted Oct 20, 2025 - 02:46 PDT

Identified

Starting at 06:55 UTC on October 20, 2025, Abnormal is experiencing service degradation across multiple security products due to infrastructure issues with a third-party cloud provider (Amazon Web Services). During this time, some customers may experience issues accessing Portal, delays in email processing, threat detection, and remediation activities. Abnormal is actively working with the provider to resolve the underlying infrastructure issues and will reprocess all affected emails once services are fully restored to ensure complete security coverage.
Posted Oct 20, 2025 - 00:48 PDT
This incident affected: Inbound Email Security (IES), Email Productivity (EPR), Account Takeover Service (ATO), AI Security Mailbox (AISM) and Platform (Portal Application, Security Information and Event Management API (SIEM API), Security Orchestration, Automation Response API (SOAR API)).