Degradation of Inbound Email Protection
Incident Report for Abnormal Security
Resolved
The impacted remediation actions were reprocessed as of 10:00 AM PT 09/30.

Incident Summary: Starting September 29, 2023, at 07:06 am PDT we experienced an issue affecting our Inbound Email Protection service causing False Negatives and affecting Abuse Mailbox remediations.

Affected Services: Inbound Email Protection & Abuse Mailbox
Severity Level: Major
Incident Start Time: September 29, 2023, 07:06 am PDT
Resolution Time: September 29, 2023, 10:49 am PDT

Questions?:
If you're experiencing any issues following the resolution, please get in touch with us immediately at support@abnormalsecurity.com.
Posted Sep 30, 2023 - 12:24 PDT
Update
Major Incident Update

The reprocessing of impacted remediation actions is still progressing.

Next Update: Upon completion of the replay of messages.

Incident Summary: Earlier today we had an issue affecting our Inbound Email Protection service causing False Negatives and affecting Abuse Mailbox remediations.
Affected Services: Inbound Email Protection & Abuse Mailbox
Severity Level: Major
Incident Start Time: September 29, 2023, 07:06 am PDT
Resolution Time: September 29, 2023, 10:49 am PDT

Questions?:
For more details or immediate concerns, contact us at support@abnormalsecurity.com.
Posted Sep 30, 2023 - 08:03 PDT
Update
Major Incident Update

The reprocessing of impacted remediation actions is still progressing.

Next Update: Upon completion of the replay of messages.

Incident Summary: Earlier today we had an issue affecting our Inbound Email Protection service causing False Negatives and affecting Abuse Mailbox remediations.
Affected Services: Inbound Email Protection & Abuse Mailbox
Severity Level: Major
Incident Start Time: September 29, 2023, 07:06 am PDT
Resolution Time: September 29, 2023, 10:49 am PDT

Questions?:
For more details or immediate concerns, contact us at support@abnormalsecurity.com.
Posted Sep 29, 2023 - 22:36 PDT
Update
Major Incident Update

The reprocessing of impacted remediation actions is still progressing.

Next Update: 2 hours

Incident Summary: Earlier today we had an issue affecting our Inbound Email Protection service causing False Negatives and affecting Abuse Mailbox remediations.
Affected Services: Inbound Email Protection & Abuse Mailbox
Severity Level: Major
Incident Start Time: September 29, 2023, 07:06 am PDT
Resolution Time: September 29, 2023, 10:49 am PDT

Questions?:
For more details or immediate concerns, contact us at support@abnormalsecurity.com.
Posted Sep 29, 2023 - 19:01 PDT
Monitoring
Incident Summary: We are currently investigating an issue that is affecting our Inbound Email Protection service causing False Negatives and also affecting Abuse Mailbox remediations.
Affected Services: Inbound Email Protection
Severity Level: Major
Incident Start Time: September 29, 2023, 07:06 am PDT
Latest Developments:
We have identified the root cause and a fix has been applied. We have started the reprocessing of messages during the affected time.

Resolution Time: September 29, 2023, 10:49 am PDT
Updated Workarounds: N/A
Next Update: Upon completion of the replay of messages.
Questions?:
For more details or immediate concerns, contact us at support@abnormalsecurity.com.
Posted Sep 29, 2023 - 11:18 PDT
Identified
Incident Summary: We are currently investigating an issue that is affecting our Inbound Email Protection service causing False Negatives.
Affected Services: Inbound Email Protection
Severity Level: Major
Incident Start Time: September 29, 2023, 07:06 am PDT
Latest Developments:
We have identified the root cause and are working to identify a fix.
Revised Estimated Resolution Time: TBD
Updated Workarounds: N/A
Next Update: 10:30 PDT
Questions?:
For more details or immediate concerns, contact us at support@abnormalsecurity.com.
Posted Sep 29, 2023 - 10:03 PDT
Investigating
Incident Summary: We are currently investigating an issue that is affecting our Inbound Email Protection service causing False Negatives.
Affected Services: Inbound Email Protection
Severity Level: Major
Incident Start Time: September 29, 2023, 07:06 am PDT
What We're Doing: We are currently investigating to determine the root cause of this issue.
Estimated Resolution Time: TBD
Current Workarounds: N/A
Next Update: 9:30 am PDT
Questions?:
For any immediate concerns, please contact us at support@abnormalsecurity.com.
Posted Sep 29, 2023 - 09:04 PDT
This incident affected: Inbound Email Protection.