Delayed Processing of Messages
Incident Report for Abnormal Security
Resolved
This incident has been resolved.
Posted Apr 21, 2020 - 14:55 PDT
Monitoring
Our engineering team has deployed and verified fixes, and Inbound Email Protection & Abuse Mailbox Services have returned to regular operational health.

We are currently retroactively re-processing all emails from the affected time period.
Posted Apr 21, 2020 - 10:28 PDT
Identified
Our engineering team has identified likely root cause issues, and is currently deploying & monitoring fixes.
Posted Apr 21, 2020 - 09:52 PDT
Investigating
We are currently experiencing a delay in processing of messages. Our engineering team is actively investigating.
Posted Apr 21, 2020 - 08:13 PDT
This incident affected: Abuse Mailbox Service and Inbound Email Protection.